Nissan Armada & Infiniti QX56 Forums banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
178 Posts
Discussion Starter #1
My wife actually let me have the Armada for a few minutes yesterday. While leaving my brother's house I noticed that the console indicated that I was in 4WD when the dial was on 2WD. This lasted for a few minutes. I turned the dial while driving and also shifted in to neutral. The car then indicated it was back to 2WD.

I did not hear or feel any change from 2wd to 4wd or from 4wd back to 2wd so I don't think the car actually shifted. Has anybody else seen this issue?
 

·
Premium Member
Joined
·
178 Posts
Discussion Starter #2
RKS said:
My wife actually let me have the Armada for a few minutes yesterday. While leaving my brother's house I noticed that the console indicated that I was in 4WD when the dial was on 2WD. This lasted for a few minutes. I turned the dial while driving and also shifted in to neutral. The car then indicated it was back to 2WD.

I did not hear or feel any change from 2wd to 4wd or from 4wd back to 2wd so I don't think the car actually shifted. Has anybody else seen this issue?

Don't know if anyone else has experienced this yet. It is now becoming a daily occurance. I am taking it in on Monday to get this and 2 squeeks looked at. I can't seem to locate where the noises come from but if I put my arms on the armrest they go away...
 

·
Premium Member
Joined
·
1 Posts
I just purchased my 05 LE a week ago and a few days ago I noticed that "4wd" was displayed on the dash, when the transfer case was in "auto". As it is a new vehicle, I assumed that this was normal, but I have not seen it lit since.

I will keep a eye on it.
 

·
Premium Member
Joined
·
178 Posts
Discussion Starter #4
smcat38 said:
I just purchased my 05 LE a week ago and a few days ago I noticed that "4wd" was displayed on the dash, when the transfer case was in "auto". As it is a new vehicle, I assumed that this was normal, but I have not seen it lit since.

I will keep a eye on it.
I don't think it is supposed to show up but I may be incorrect. I had it in Auto during our 1' of snow last week and it never displayed "4WD" but it did indicate "Slip" a few times but it performed like a champ.
 

·
Premium Member
Joined
·
129 Posts
RKS said:
I don't think it is supposed to show up but I may be incorrect. I had it in Auto during our 1' of snow last week and it never displayed "4WD" but it did indicate "Slip" a few times but it performed like a champ.
As you probably know...but others may not...the "Slip" indication is normal. It occurs when traction is lost and power is being direct to other wheels....

The only thing I don't like about it...is that it reduces power too much...rather than transfer existing desired power .... it can bog you down a bit...till you let off the gas.....

Try it out in the snow... and then turn VDC off...much more fun to drive that way....
 

·
Premium Member
Joined
·
6 Posts
4WD light on - Vehicle down for weeks

We bought our '04 and within 5 miles of leaving the dealership the 4WD warning light came on (We were in 2WD mode). It goes on and off. Changing from 2WD to Auto to 4 HI makes no difference.

We took it back to the dealer and they said they could not find a problem. We took it to another dealer and they said it was a bad switch - order part and wait.

Switch was replaced and off we drive and within 5 miles, the light comes on again (obviously they don't check their work). We turn around a go back and schedule a time to leave the vehicle.

We drop off the vehicle on Thursday 1/12/05 and haven't seen it since. Nissan "downed" the vehicle due to a bad transfer case. There were delays in getting a new part in and it finally arrived 1/25 - damaged. Now another transfer case is on backorder till 2/7/05.

We bought the car used (10K miles) on 12/11/04. When we expect to get it back on 2/11/05, Nissan will have had our car in their shop for about 40 days of the 2 months of our ownership. It has been in 5 times for a number of reasons. I will post details on out dealings with Nissan. I would recommend taking the vehicle in if the 4WD light is on - it may be a real problem.
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
4 Participants
pistol
Nissan Armada & Infiniti QX56 Forums
Club Armada is the premier Nissan Armada forum! Here you can discuss and review your favorite SUV with fellow owners.
Full Forum Listing
Top