Nissan Armada & Infiniti QX56 Forums banner

1 - 15 of 15 Posts

·
Premium Member
Joined
·
150 Posts
Discussion Starter #1
my 2005 nissan armada just started dying on me while the truck was running.
no problem with battery or starter. just routinely died while running/engine shut off.
happened 3x.

have not used the car since and have started it several times and let it warm up for
5 mins no problem.

my mechanic says it could be the fuel filter? not the in tank one but the outside fuel filter?
if so where can i get this? I've tried eBay and courtesy parts can anyone point me in the right direction?

thanks

carlo
 

·
Super Moderator
Joined
·
5,222 Posts
if memory serves and i will be corrected, the petrol filter is inside the tank.

could be an IPDM issue also. there was a recall/tsb for the petrol pump filter a while back.
 

·
Premium Member
Joined
·
150 Posts
Discussion Starter #3
if memory serves and i will be corrected, the petrol filter is inside the tank.

could be an IPDM issue also. there was a recall/tsb for the petrol pump filter a while back.
you its inside but according to my mechanic there is also one outside the tank? could be wrong but this is the part
I'm talking about and if anyone knows the part number would super appreciate it.


 

·
Super Moderator
Joined
·
5,222 Posts

·
Premium Member
Joined
·
14 Posts
There is no outside fuel filter for the armada or QX56, the fuel filter is incorporated into the fuel pump which is inside the gas tank. The fuel pump plastic assembly has two filters, one outside filter, and then one attached on the fuel pump inside the plastic assembly. I just changed my fuel pump in my driveway last week as mines was dying and I had to get it fixed so I can get my Uprev properly tuned.

Your problem sounds more like a IPDM problem instead of a fuel problem. Search on google "armada ipdm" and it'd give you tricks and tips to get it fixed. I think there's even videos on YouTube if I'm not mistaken.
 

·
Premium Member
Joined
·
150 Posts
Discussion Starter #6
thanks so much guys you saved me some time and money.
i live in manila, PI so everything as in every part is ordered from the states,
not to mention the Tech guys at nissan aren't very helpful as dealership
doesn't carry this model locally.

have since purchased 2 relays for 8$. if it fixes it it will be the best 8$ I've spent!
thank you
 

·
Premium Member
Joined
·
150 Posts
Discussion Starter #9
ok just received the parts. swapped out the first relay based on youtube instructions and the car
worked. drove it for half the day no problems. the following day i was able to use the car in the morning
but when i attempted to start it it would not start engine fires up but then dies after a millisecond.

i repeated the procedure of swapping the relay, unplug and plug and it temporarily solved the problem.
was able to drive it back home but upon attempting to start it the following day it would not start.

I'm getting very paranoid, planning on bringing it in to nissan and hopefully they can figure it out.
in my case the IPDM swap doesn't work and hasn't solved my problem
 

·
Premium Member
Joined
·
150 Posts
Discussion Starter #10
truck won't start at all. engine fires up then dies down.
i can't even drive it to the shop to get it sorted.
 

·
Super Moderator
Joined
·
5,222 Posts
are you able to get a scan tool to the obd port? this can help point you in the right direction...

cam position sensors.. ipdm, petrol pump, petrol rail.. high pressure petrol pump... soooooo many things........
 

·
Premium Member
Joined
·
150 Posts
Discussion Starter #12
are you able to get a scan tool to the obd port? this can help point you in the right direction...

cam position sensors.. ipdm, petrol pump, petrol rail.. high pressure petrol pump... soooooo many things........
not where my truck is. its parked in my office.
i was hoping to get it started to drive to the nissan dealership but looks like
its looking impossible.

i seriously doubt they can solve it as the nissan armada is not sold locally and is an imported model. but id rather it be there problem than mine. this armada ordeal is a pain in the %^%&
my nissan patrol has had no gremlins or glitches since day 1.
 

·
Super Moderator
Joined
·
5,222 Posts
yeah my nissan patrol aka 2012 qx56 has been solid. something about born and raised in japan.. :p

you can get a scan tool from a internet site and plug it up or bluetooth it to your phone. i would suggest you start there so you are not chasing your tail.
 

·
Registered
Joined
·
1 Posts
my 2005 nissan armada just started dying on me while the truck was running.
no problem with battery or starter. just routinely died while running/engine shut off.
happened 3x.

have not used the car since and have started it several times and let it warm up for
5 mins no problem.

my mechanic says it could be the fuel filter? not the in tank one but the outside fuel filter?
if so where can i get this? I've tried eBay and courtesy parts can anyone point me in the right direction?

thanks

carlo
where exactly are the in line gas filters located ?please help thank you:)
 

·
Premium Member
Joined
·
1,099 Posts
There is no inline fuel filter. The only fuel filter is attached on the bottom of the in-tank fuel pump.
 
1 - 15 of 15 Posts
Top