Nissan Armada & Infiniti QX56 Forums banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
2 Posts
Discussion Starter · #1 ·
New here, I've watching the board learning about the Armada's. We bought ours in June with a build date of May 05 hoping the factory fixed the brakes. I was wrong always had tons of brake dust. After about 5,000 miles you could feel the brakes. Dropped it off Sat. for the brakes and the drivers window was loose. They put new rotors and pads all the way around. The brakes feel better the rotors look bigger. Not sure. Landers Nissan in MS has the brake fix in-stock hope this helps someone in my area.

Window still loose oh well that will be another trip.
Tommy
 

·
Premium Member
Joined
·
3,408 Posts
Tommytbone said:
New here, I've watching the board learning about the Armada's. We bought ours in June with a build date of May 05 hoping the factory fixed the brakes. I was wrong always had tons of brake dust. After about 5,000 miles you could feel the brakes. Dropped it off Sat. for the brakes and the drivers window was loose. They put new rotors and pads all the way around. The brakes feel better the rotors look bigger. Not sure. Landers Nissan in MS has the brake fix in-stock hope this helps someone in my area.

Window still loose oh well that will be another trip.
Tommy
Welcome, and Glad to hear the brakes are fixed ;)
 

·
Premium Member
Joined
·
4,362 Posts
Sorry to hear about the window. Glad to hear about the brakes. Good luck!
 

·
Premium Member
Joined
·
4,362 Posts
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top