Nissan Armada & Infiniti QX56 Forums banner

1 - 20 of 32 Posts

·
Premium Member
Joined
·
9 Posts
Discussion Starter #1
While experiencing virtually every problem discussed in this forum I have one that I have not noticed discussed yet. I have a loud popping/creaking noise coming from the front end of my vehicle. It is most noticeable when the wheels are turned and I am going over uneven payment. Another example would be backing out of my driveway, the wheels are turned and as it makes the small drop from my drive way to the road surface it make this noise. I can even feel it in the brake pedal at times. I searched the Titan Web site and did find a reference to the tie rod ends making a noise, but my dealer says they are fine. Of course they cannot duplicate the noise during their test drives, even though I have duplicated it with them in the vehicle. I have gone to battle several times with my dealer to get repairs done with the knowledge I have gained from this forum. Any thoughts on this problem that I might use to get this issue resolved? Thanks for the help.
 

·
Premium Member
Joined
·
248 Posts
Something tells me that the axle nut needs to be removed, regreased, and re-torqued.
 

·
Premium Member
Joined
·
60 Posts
dkerns said:
While experiencing virtually every problem discussed in this forum I have one that I have not noticed discussed yet. I have a loud popping/creaking noise coming from the front end of my vehicle. It is most noticeable when the wheels are turned and I am going over uneven payment. Another example would be backing out of my driveway, the wheels are turned and as it makes the small drop from my drive way to the road surface it make this noise. I can even feel it in the brake pedal at times. I searched the Titan Web site and did find a reference to the tie rod ends making a noise, but my dealer says they are fine. Of course they cannot duplicate the noise during their test drives, even though I have duplicated it with them in the vehicle. I have gone to battle several times with my dealer to get repairs done with the knowledge I have gained from this forum. Any thoughts on this problem that I might use to get this issue resolved? Thanks for the help.

I have the same problem, noticed mostly on speed bumps with a slight turn of the tires. The first BS answer I've been given is to use silicone spray for the urethane bushings....ha-ha-ha.... silicone and duct tape will keep her runnin' good!!!!! No solution yet...but I am hoping for a good discussion on this forum.
 

·
Premium Member
Joined
·
32 Posts
I have the same creaking noise coming from (sounds like from the suspension area). Almost every time I pull into my drive way from the street it makes this noise. My drive way is inclined by the way. The wheel is turned right or left when this happens. I am going to bring this up at my next service. But it sounds as if the dealer is not too concerned to fix this problem after reading other owners outcomes. What can we do to have this corrected? A New $40,000 SUV should not sound like it’s going to fall apart when it’s going up the side of a hill….let alone a drive way or a speed bump. :confused:

I am a very detailed person. I seem to notice almost everything. Every time I drive my Armada I start the car and drive the car with no other noises to distract me from hearing unfamiliar sounds. The dealer seems to be blind to a lot of complaints that customers have.
 

·
Premium Member
Joined
·
13 Posts
dkerns said:
While experiencing virtually every problem discussed in this forum I have one that I have not noticed discussed yet. I have a loud popping/creaking noise coming from the front end of my vehicle. It is most noticeable when the wheels are turned and I am going over uneven payment. Another example would be backing out of my driveway, the wheels are turned and as it makes the small drop from my drive way to the road surface it make this noise. I can even feel it in the brake pedal at times. I searched the Titan Web site and did find a reference to the tie rod ends making a noise, but my dealer says they are fine. Of course they cannot duplicate the noise during their test drives, even though I have duplicated it with them in the vehicle. I have gone to battle several times with my dealer to get repairs done with the knowledge I have gained from this forum. Any thoughts on this problem that I might use to get this issue resolved? Thanks for the help.
I had a similar issue - took it to the dealer and they "re-torqed the steering rack bolts" - seems to have solved the problem for me
 

·
Premium Member
Joined
·
9 Posts
Discussion Starter #6
Thanks for the reply!

jweek said:
I had a similar issue - took it to the dealer and they "re-torqed the steering rack bolts" - seems to have solved the problem for me
Finally getting some activity on this post and a suggestion. I seem to make an apointment about every two weeks for problems so I will ask them to check the steering rack bolts. I am getting a little tired of the 'everythings tight' and 'can't duplicate the problem' responses for this issue. With all the rattles, vibrating parts, pops, squeaks, and creaks when I drive this vehicle I am supprised I don't see a trail of parts when I look in the rear view mirror. Of course it is a little difficult to focus when the mirrors shake so much. I did notice if you drive with the windows down and the stereo off you can enjoy a whole new set of noises coming from the outside of the vehicle. :D
 

·
Premium Member
Joined
·
9 Posts
Discussion Starter #7
After a year the dealer finally found the source of the noise. It was really two problems. They found excessive play in both outer sway bar links. The sway bar bushings were split and would not stay in the retainers. They replaced the sway bar links and bushings. The second noise (cracking/creaking when pulling into the driveway) was found by using 'chasis ears'. They stated the lower control arm bushings were binding against the frame. They remove the control arm and lubed the bushings, reposition the control arm. I am not to happy that it took over a year to find this, but happy the dealer stuck with it. I am noise free now in the front end of the vehicle. I hope this helps someone else in diagnosing their problem.
 

·
Premium Member
Joined
·
910 Posts
Thanks for the info dkerns, this surely will be a help to other owners.

Sorry you have such a crappy dealership. One thing I've learned in my Armada experience is how important a good service department is. It can mean the difference between loving and hating your new ride!

Now that your dealer has finally pulled their collective heads out of their a$$, I hope that you can enjoy your Armada. It really is a great vehicle and the best large SUV out there. What year is yours, by the way?
 

·
Premium Member
Joined
·
4,363 Posts
What he said. ;)
 

·
Premium Member
Joined
·
1,258 Posts
For any creaking or squeaking coming from underneath, get the wheel hub TSB done first. That got rid of it for me.
 

·
Premium Member
Joined
·
66 Posts
Noise In Omter

Hello

I have problem with the with noise in the omater when i turn right or left i hear squuuzz noise any one knows how to fix it pleasssssse
 

·
Premium Member
Joined
·
1,258 Posts
Cool_armada said:
Hello

I have problem with the with noise in the omater when i turn right or left i hear squuuzz noise any one knows how to fix it pleasssssse
CHeck your power steering fluid. a little noise is normal. If your fluid is topped off and you are still getting noise turning the streering wheel, time to see dealer.
 

·
Premium Member
Joined
·
9 Posts
Discussion Starter #14
adjmcloon said:
Thanks for the info dkerns, this surely will be a help to other owners.

Sorry you have such a crappy dealership. One thing I've learned in my Armada experience is how important a good service department is. It can mean the difference between loving and hating your new ride!

Now that your dealer has finally pulled their collective heads out of their a$$, I hope that you can enjoy your Armada. It really is a great vehicle and the best large SUV out there. What year is yours, by the way?
My Armada was built Oct 2004.
 

·
Premium Member
Joined
·
1,707 Posts
Having same problem!! So what do you have to do to get it fixed? Sorry too lazy to look through this topic lol :eek: Do you have to go to the dealer?
 

·
Premium Member
Joined
·
1,707 Posts
hellloooo? any1 out there to lend a hand..please?
 

·
Premium Member
Joined
·
258 Posts
Late to this topic ... but I was thinking along the lines of the sway bar end links. Turning/uneven surface/clunking noise points to these. Same identical symptoms and cause in my Volvo. Excessive play is hard to figure out - if you are under the car/truck and pull on them they seem fine.

Repair is best done by the shop. Not only is it all under warranty, but working suspension components is always a fair amount of work.
 

·
Premium Member
Joined
·
37 Posts
BUMP! Have there been more of these problems? I am wondering if this is whats wrong with mine. The sway bar sounds about right with my original symptoms.
 

·
Premium Member
Joined
·
604 Posts
Folks,
I believe I have this problem as well on my 05 MADA LE. It start about a month ago. It sounds like a binding and popping noise when I start to back up my truck from garage with steering slowly turning.
How should I explain to the dealer when I ask them to check it out? The noise is not really obvious but it's there. I don't want to hear from the service advisor says, "we cannot recreate your problem." or some s**t.
 
1 - 20 of 32 Posts
Top