Nissan Armada & Infiniti QX56 Forums banner
1 - 2 of 2 Posts

·
Premium Member
Joined
·
1,706 Posts
Discussion Starter · #1 ·
Hi guys. My dad and I noticed a front-end squeeking noise when the Armada went over a speed bump. We went over 3 speed bumps, and thrice the squeek happened. This same noise came last year too, around fall/winter time. I think it's from the suspension. Any clue on to how to fix this? Last year and I remember that the dealer said that my dad probably got a car wash and it was winter, so the front suspension stiffened up a little. I think he was on drugs lol b/c why would the noise happen right now? It's around 11 (degrees) celcius in Toronto, which is 52 fahrenheit (correct me if i'm wrong), and that's pretty warm and we didn't get any car washes lately...
 

·
Premium Member
Joined
·
547 Posts
I agree... the dealer was getting high off his own supply. I have some weird noises going on under my truck too and the dealer said his mechanic didn't hear anything when he drove it. Will try the other dealer in my town soon.

hullio said:
Hi guys. My dad and I noticed a front-end squeeking noise when the Armada went over a speed bump. We went over 3 speed bumps, and thrice the squeek happened. This same noise came last year too, around fall/winter time. I think it's from the suspension. Any clue on to how to fix this? Last year and I remember that the dealer said that my dad probably got a car wash and it was winter, so the front suspension stiffened up a little. I think he was on drugs lol b/c why would the noise happen right now? It's around 11 (degrees) celcius in Toronto, which is 52 fahrenheit (correct me if i'm wrong), and that's pretty warm and we didn't get any car washes lately...
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top