Nissan Armada & Infiniti QX56 Forums banner
1 - 2 of 2 Posts

·
Premium Member
Joined
·
41 Posts
That just makes one smile :). What lift are you running? it doesn't look like you have anyof a 'squat' in the rear. Are you running any driveshaft spacers? I ask because I just had mine lifted last week, has a minor squat in the rear (no spring spacers, just 5.5" blocks) Then again, I'm parking uphill in a driveway so that may be it. Still don't even have the damn thing aligned yet :D
Wheel Tire Automotive parking light Land vehicle Vehicle
 

·
Premium Member
Joined
·
41 Posts
Thanks, I realized the squat was really only in my driveway, otherwise looks pretty even when I'm out on the flats. Great deal on your rig? I bought this one about 5 years ago with 151k miles on it for $5500. Came with the 22's but had road tires on it. The paint is in bad shape and I think they must have had it parked in a field or something in a while. I had to immediately dump 2000 bucks in it, replacing all the brakes, brake booster, front wheel hubs(ABS sensors), put some different running boards on it, added a tow package, etc. It's been such a fun ride. I have about 178k on it now and it runs like a champ, doesn't leak anything :). Also learned 2 years later that the motor mount bolts were missing! That was SCARY. I put some in right away, but part of me believes the reason they were out was to do the catalytic converters, I'm hopeful because I dont want to have to do them lol.
 
1 - 2 of 2 Posts
Top