Nissan Armada & Infiniti QX56 Forums banner
1 - 5 of 5 Posts

·
Registered
2012 Armada
Joined
·
7 Posts
Discussion Starter · #10 ·
Your Armada looks Awesome! Nice work. That body style looks great jacked up with big wheels. I honestly don't know squat about lift kits or any of that stuff. I bought my Armada just like you see it. Found it at a dealership near the house when I was there to look at a Tahoe they had for sale. I seen the Armada and loved how it looked jacked up on 22s. Told the dealership if they put new tires on it I'd buy it. Got it for $16k with new Nitto grapplers on it and 96k miles 2012 model, I thought it wasn't a bad deal. It's has four Bilstein shocks on the rear axle, two Bilstein shocks on the front end, Magna flow exhaust with side dumps in front of each back tire. I wish I knew how many inches it's lifted. It looks close to the same height as yours just from the looks on the picture.
 

·
Registered
2012 Armada
Joined
·
7 Posts
Discussion Starter · #12 ·
Thanks, I realized the squat was really only in my driveway, otherwise looks pretty even when I'm out on the flats. Great deal on your rig? I bought this one about 5 years ago with 151k miles on it for $5500. Came with the 22's but had road tires on it. The paint is in bad shape and I think they must have had it parked in a field or something in a while. I had to immediately dump 2000 bucks in it, replacing all the brakes, brake booster, front wheel hubs(ABS sensors), put some different running boards on it, added a tow package, etc. It's been such a fun ride. I have about 178k on it now and it runs like a champ, doesn't leak anything :). Also learned 2 years later that the motor mount bolts were missing! That was SCARY. I put some in right away, but part of me believes the reason they were out was to do the catalytic converters, I'm hopeful because I dont want to have to do them lol.
I just replaced my cats last week $2,100 for them with new exhaust manifolds. I had to replaced the valves covers and seals after I bought mine cuz it started dumping white smoke for a minute after start up and was burning a lot of oil so I think those bad valve seals might have messed up the cats. What year is your Armada?
 
1 - 5 of 5 Posts
Top