Nissan Armada & Infiniti QX56 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
I have a 2019 Armada. When we set the GPS, the arrival time for our trip is always way off. For example, I just took a trip to Asheville. It's normally a 3.5 hr trip. When I first put the destination into the gps, it said the trip was going to take over 4.5 hrs. As we traveled, the eta would slowly come down. Is there a way to adjust this? Are others having the same problem?

Thanks,

Zac
 

·
Super Moderator
Joined
·
5,710 Posts
your experience doesn't sound like a "problem".

GPS is government controlled. They can turn it off, manipulate it at will and do whatever they want, whenever they want. Sometimes I will see the map put me on some other street a mile or so away and ive seen it completely off. Perhaps you experienced some of this on your trip.

That said, sounds like the GPS was performing properly. as your speed increases/decreases, this factors into the time. this is how its bahaved to me for the years and years ive used gps on armadas and my qx.

also on google maps, which is more accurate with realtime travel than the in-built GPS. ive seen it base my time on a destination and as my driving goes on, it will fluctuate +/-.
 

·
Registered
Joined
·
10 Posts
I have a 2019 Armada. When we set the GPS, the arrival time for our trip is always way off. For example, I just took a trip to Asheville. It's normally a 3.5 hr trip. When I first put the destination into the gps, it said the trip was going to take over 4.5 hrs. As we traveled, the eta would slowly come down. Is there a way to adjust this? Are others having the same problem?

Thanks,

Zac
I had the same issue. The problem is that the default settings for average speeds (highway, main road, residential, etc.) are too low. In the Nissan Connect manual it describes how to change them (I have an '18 and it's in section 6). Basically you push Setting->Navigation->Set Average Speeds.

Hope this helps!
 

·
Registered
Joined
·
37 Posts
Discussion Starter #4
James, that is very helpful, thanks. I will take a look at that this weekend.

I played around with the settings over the weekend and it really made a difference. I went on a 35 mile trip that I make on a regular basis. Before I adjusted the settings, it said the trip would take 58 mins. After I adjusted them, it said the trip would take 44 mins and it only missed it by 2 mins which is really accurate compared to the gps's we have in our other cars. Thanks again for your help.

Have a great day,

Zac
 
1 - 4 of 4 Posts
Top