Nissan Armada & Infiniti QX56 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2008 Infiniti QX56. When I start it up it has a grinding noise that only lasts for maybe 30 seconds, 1 mechanic said it could be the timing chain and once the oil circulates it shuts off. It will have to be replaced eventually but isn't damaging right now. Then I was told it was related to BLSD. I have attached photos because nobody can tell me what this dash light means and no check engine light is on. My rear tires have a slight angle in but nothing major. So I'm just looking for someone that can send me in the right direction because clearly these local Mechanics don't know crap about Infiniti and the closest dealer is 3 hours away from me! Thank you!
50175
50176
50177
 

·
Registered
Joined
·
116 Posts
The only dash lights I see are your headlights are on, and seat belt isn't buckled. The slant in the tires is either your air shocks have failed or they aren't adjusted properly. This question may come off as condescending, and that is not how I mean it, but since you don't know anyone's background on forums...Is the grinding you are hearing the starter? Or is it more a squealing noise, because that would be your belt.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I was told there is a leak in my hydraulic hose. So it continues to run and eventually shuts off by itself when it's not getting the pressure to lift it. Sounds expensive 🤦‍♀️ Just the passenger side

The only dash lights I see are your headlights are on, and seat belt isn't buckled. The slant in the tires is either your air shocks have failed or they aren't adjusted properly. This question may come off as condescending, and that is not how I mean it, but since you don't know anyone's background on forums...Is the grinding you are hearing the starter? Or is it more a squealing noise, because that would be your belt.
It's an air leak in my hose so the hydraulic is continuously trying to lift the truck so that's the noise I hear. Thank you! Appreciate your help!
 

·
Registered
Joined
·
116 Posts
I was told there is a leak in my hydraulic hose. So it continues to run and eventually shuts off by itself when it's not getting the pressure to lift it. Sounds expensive 🤦‍♀️ Just the passenger side



It's an air leak in my hose so the hydraulic is continuously trying to lift the truck so that's the noise I hear. Thank you! Appreciate your help!
If it is for the suspension, then it is just compressed air, not hydraulic fluid. The 2008 didn't have the hydraulic body control system. If it is truly a leak in the air line, then a new line from Infiniti is about $50.00, or I made my own for about $20.00.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
If it is for the suspension, then it is just compressed air, not hydraulic fluid. The 2008 didn't have the hydraulic body control system. If it is truly a leak in the air line, then a new line from Infiniti is about $50.00, or I made my own for about $20.00.
Ya, I did mean the air leak not the fluid. I'm taking it in next week. Not gonna try this myself lol thank you very much for your help
 
1 - 6 of 6 Posts
Top