Nissan Armada & Infiniti QX56 Forums banner
1 - 20 of 29 Posts

·
Premium Member
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Guys need some info have 05 le. When driving on bumpy roads the front end seems to jump. It feels like the truck come off the ground and moves over. I changed the tires to xterrains seems better but still does it. Have tried 30psi to 35psi same difference any ideas. Was thinking of trying the Q56 struts some
say they are softer riding. Thanks in advance.
 

·
Premium Member
Joined
·
37 Posts
I have an 04 LE with the same issues. I recently had an 06 LE for a 4 day test drive and was blown away by the difference. Has the suspension been changed on the 06's or is there something wrong with my 04?

Any help would be appreciated.

Thx
 

·
SHIFT_Moderator
Joined
·
13,189 Posts
Changes were made in the 06

There were a few changes made in the 06 models to correct some of the original bugs. I think they were brakes, paint, and suspension. There may be others. I drive an 06 and haven't experienced a lot of the issues from those I have read on the 04 and 05 models.
 

·
Premium Member
Joined
·
3 Posts
Discussion Starter · #6 · (Edited)
Thanks guys but how can we find out if and what suspension changes have been made. The xterrains helped a little but the problem is still there. It is definately not the Conti tires causing it to do this. I don't know if the struts are no good or are just to heavy for the vehicle.
 

·
Premium Member
Joined
·
164 Posts
Ratard, I've been having the same type of sensation. I have an 04 LE 2wd with 43000 miles. It's only in the last 6 months that I have felt a difference. I Changed fro Wranglers to Cross-Terrains and that has helped a bit, but I still notice some "looseness" in the front suspension. BTW I just got it back after two days at the dealer to try and correct this. The dealers verdict? I just need to "get used to the way this type of vehicle feels." This to someone who has driven 3/4 ton or larger vehicles 50000 miles a year for the last 20 years. I laughed at the lady assured her I would drive it for a few days and see if it was any better.
I'm wondering if there are aftermarket struts that would help? Anybody got info?
 

·
Premium Member
Joined
·
5 Posts
bump for an answer to this issue.

I have an '05 w/19.5k miles on it with 22" wheels that is doing the exact same problem - feeling all "loose" when traveling over bumpy roads. The dealer told me that I need to get a "big break kit" because I have the larger wheels. I told him "you sold it to me this way" and that's where we stand.

I hope to hear from them soon. In the mean time, I don't see how a "big break kit" would fix the "loose" feeling you get as you ride over bumpy roads. It almost seems the shocks are too weak for the added weight (from the tires/wheels).

Anyhow, I hope someone finds an answer.
 

·
Premium Member
Joined
·
117 Posts
i have a 05 QX56 and i have changed to xterrians hopeing to solve the harsch ride but it is still rough.. i have talk to Infiniti about it and his response was "all Infiniti have rough rides, you should drive a FX thats even worse" .. i dont know what to do i want to get rid of the truck now.. My cousins 05 Navigator with Xterians has a much smoother ride, the navigator has air suspension factory.


fiddlyD
 

·
SHIFT_Moderator
Joined
·
13,189 Posts
fiddlyD said:
i have a 05 QX56 and i have changed to xterrians hopeing to solve the harsch ride but it is still rough.. i have talk to Infiniti about it and his response was "all Infiniti have rough rides, you should drive a FX thats even worse" .. i dont know what to do i want to get rid of the truck now.. My cousins 05 Navigator with Xterians has a much smoother ride, the navigator has air suspension factory.


fiddlyD
Hey Bro! Do what you gotta do!

I personally do not accept the excuse from folks (dealers) that "They all do that!" You know from others here on the site that they all don't.

So, the ball is in your court to accept what they say and settle, accept it and get something else, or don't accept it and get it solved.

Whatever you decide, do what's best for you and your family. Best of luck on your decision.
 

·
Premium Member
Joined
·
375 Posts
I dont know about the 05, but this is normal for the 04. DO a search this been discussed a thousand times. good luck
 

·
SHIFT_Moderator
Joined
·
12,985 Posts
fiddlyD said:
i have a 05 QX56 and i have changed to xterrians hopeing to solve the harsch ride but it is still rough.. i have talk to Infiniti about it and his response was "all Infiniti have rough rides, you should drive a FX thats even worse" .. i dont know what to do i want to get rid of the truck now.. My cousins 05 Navigator with Xterians has a much smoother ride, the navigator has air suspension factory.
My Mom and Pop just bought a Navigator this last December 31st. It's not much smoother than my LE and we have very rough roads around here. Sounds like a Strut problem to me, I'd insist on them replacing the Struts before I dumped the truck. If you don't mind going after market, I've had some Monroe struts on a Durango that rode much smoother than OEM.
 

·
Premium Member
Joined
·
213 Posts
I have an 05 with stock conti's and it has the same problem. Installing Rancho rs9000x adjustable shocks this weekend which from what I have read are a little better than stock but not as good as the other more expensive coil overs that can be purchased for the front suspension. I am doing the prg lift so I thought I would go ahead and replace the front shocks. From what I understand, the shock rebound rate is what needs to be improved. Lots of great info on this forum and also do a search over at club titan.
 

·
Premium Member
Joined
·
7 Posts
Just came back from pismo, catching air all weekend. First couple of times, I
tought something had broke. The suspension is set up for smooth roads or slow speed off roading. Thinking about changing out front struts/coils for
more high speed proformance!! Anyways my 2 cents...
:hi:
 

·
Premium Member
Joined
·
506 Posts
Welcome JP!
 

·
SHIFT_Moderator
Joined
·
13,189 Posts
jimmypop said:
Just came back from pismo, catching air all weekend. First couple of times, I
tought something had broke. The suspension is set up for smooth roads or slow speed off roading. Thinking about changing out front struts/coils for
more high speed proformance!! Anyways my 2 cents...
:hi:
Welcome to CA!
 

·
Premium Member
Joined
·
7 Posts
Sorry for not introducing my myself!! I was dying to chime in, about the suspension or the lack of. When you drive between 55 and 75mph it feels like the front end is going to rattle off. Like the space shuttle entering the earths atsmophere!! I have an 06 LE TECH package all the bells and whistles!! I needed a toy hauler (72 blazer 454 4L80e 1ton train) Oh yeah, and the Wife and Kids.. I beat my cars and dont hold back.. When catching air in the mada-wg! front end is all over the place.. Feels like Bump Steer times 10.....
Not sure what im gonna do. Thats the wifes daily driver and family truckster.. .. Maybe Kings, Donhue, Total chaos.. I just don't know, not a ton of info out there yet... Any idea??? Let me Know!! I know upgrade the front struts/coils but what rate or lbs per inch and new rear coils. Maybe end up with a 2inch suspension lift as well.


www.salonsessions.com
 

·
SHIFT_Moderator
Joined
·
12,985 Posts
If it does this only while hitched to tow, you might consider a load balancing hitch. If it does this while empty, I'd probably start also looking for loose ball-joints, stabilizer joints, steering links, etc...

Just my $.02.... There are other more qualified members that will probably chime in with some more and better advice.
 
1 - 20 of 29 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top