Nissan Armada & Infiniti QX56 Forums banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
5 Posts
Discussion Starter #1
I have a silver 2004 Armarda 4 x 4 off road, leather package, Bose sterio system. So far the only problem I have is the rear wiper was installed upside down and the front wiper make alot of noise & judder across the front glass. If any what kind of other problems should I expect from this vehicle.
 

·
Premium Member
Joined
·
5,215 Posts
I have over 16,000 miles on my '04 Armada with almost no problems. The dealer called me to replace the radio head unit, that's the only thing I have had done other than regular oil and filter changes and tire rotation. I didn't like all the brake dust so I replaced the front pads with Carbotech ones. I do have a very minor rattle somewhere in the front that I haven't found. I replaced the wiper blades and got rid of the blade "judder". Gas mileage isn't anything to brag about (I average 15.5) but the Armada is a heavy vehicle with a big engine, so I'm not unhappy with that. Overall I am very happy with the Armada.
 

·
Premium Member
Joined
·
35 Posts
I have over 7,000 on my '04 LE. My only problem so far is a very minor one ..... the driver temp setting knob sticks a bit and does not "spring back" to a neutral position. I have already talked to the dealership and they will look at it next week when I go for my oil change and replace if necessary.
 

·
Premium Member
Joined
·
896 Posts
nothing major

No brake problems, no booming, no rattles. Just radio reception, rear seat latch broke, hatch button pushed into dash, key fob split apart.. Absolutely nothing compared to my last GM truck. :)
 

·
Premium Member
Joined
·
174 Posts
7600 on mine and no issues. No booming noise, brake dust, brake shimy, etc. Just the occasional interrior squeak when it is below zero. Same with confusing the backup sensors when it is that cold. Just love driving it and can't wait for spring to detail it better.
Syko
Syko Kustomz
2004 Armada SE
Off Road
Big Tow
Journey Package
Galaxy
 

·
Premium Member
Joined
·
78 Posts
When I bought my 05, the back rest of the rear driver side seat wouldn't lock in place. So before I drove off the lot, the dealer snatched a seat from another MADA (talk about passing the buck) & replaced my bad one.

Now I'm noticing the rear audio volume control sticks a third of the time (???). Truck is only a month old, so I HOPE THIS WILL BE THE EXTENT OF MY WORRIES.

A guy at the carwash today had a 04' QX56, and he was in all disarray about all the problems he was having; he claimed Infinity was going to buy back his big Q & exchange for a 06' when they drop > I somehow doubt that,,, well I doubt it will be a clean wash (no pun)
 

·
Premium Member
Joined
·
214 Posts
I have an 04 se fully equipped with 22's navigation etc etc and the only problem I've had is the valve stem needed to be replaced because i kept losing air pressure. no brakes problems no rattles no booming sound no gas gauge problems. i love this truck. i think nissan made an effort to give us something good at a lower price and of course there are corners that needed to be cut. overall i think this truck tops any full size truck and i also feel that it's ok to read about all the little problems we're having and thank god for this web site. cheer up guys we have an awesome truck. :rrg:
 

·
Premium Member
Joined
·
3 Posts
No Problems!!

I haven't had any problems with my "Mada!! The only problem I have is slowing down on the Autobahn because I hate stopping...By the way I can tell you guys with certainty that Armada's will do every bit of 120 MPH. Not bad for 5,000 pds of metal and plastic!! I live in Germany and I've seen one other Mada and a Titan. The mechanics at my local Nissan dealer actually curse each other out over who test drives it after a service!!

SPECS:
LE with all the fixens. Smoke with steel interior.
DVD with monitor in passenger sun visor, the stock 7 incher in the center, and two in each of the secon row bucket seats.

DUB X-WANG 22 inch rims on 305/45/22 toyos for the rolling stock.

I'll post pics soon

Stogey69
 

·
Premium Member
Joined
·
1,431 Posts
stogey69 said:
I haven't had any problems with my "Mada!! The only problem I have is slowing down on the Autobahn because I hate stopping...By the way I can tell you guys with certainty that Armada's will do every bit of 120 MPH.
Stogey69
I think the US version has a speed limiter on it. I haven't tried but I think it tops out at 114? Something around that number. There was talk on another board about the subject sometime ago and the 114 is what I remember, maybe its 118?

Anyway great to have you on board
 

·
Premium Member
Joined
·
5 Posts
Discussion Starter #10 (Edited)
Now some problem are beginning to happen

Hi,
This is Roger, I've now got 5800 miles on my Mada, I am experiencing some front wheel shimmy & odd feeling under the brake pedel when trying to stop from 70 + MPH, the brake dust is excessive. I made an appointment to have the brake system check & pads replaced this morning, on arrival at the dealer they told me that they did not have any parts in stock to complete "as they call "an urgent service bullitin" I was pretty mad, but I learned along time ago "do not P--- of the mechanic". I had no choice but to make another appoinment next weekend, and keep my true feelings to myself, its a round trip of over 100 miles to see this dealer, but I will call to be sure the parts are available.
This is anoying, because I think that Nissan has built a good truck and I enjoy driving it.
Hopefully they will fix it next weekend. But if they can'nt not I don'nt know how to get this problem resolved, I never had problems such as this with my local Ford dealer, they would even provide a truck or car to drive while yours was being serviced.
 
1 - 10 of 10 Posts
Top