Nissan Armada & Infiniti QX56 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
2013 Armada- Had to have new brakes put on two weeks ago and today something felt weird and I heard a crack. WHAT is happening here? I know zero knowledge of cars, and it's now sitting at a grocery store because I was afraid to drive with the kids. Please help.
This is the left rear axle.
Shoe Hand Arm Automotive tire Leg
Tire Wheel Hood Automotive lighting Automotive tire
Automotive lighting Automotive tire Outdoor shoe Walking shoe Grey
Tire Automotive tire Tread Wood Sculpture
 

·
Registered
Joined
·
172 Posts
I'm sure you have had it towed by now, but yes whatever that white and grey wire thing is, isn't supposed to be wrapped around the axle like that. It looks like it got wrapped around and crushed the CV boot. Depending on how tight it was, the bearing inside might still be good, and you just need some fresh grease and a new boot, but it if was wrapped tight enough to damage the bearing, you will likely need a new CV Axle. The part that worries me is (from the pictures at least) it looks like the white and grey thing is a part of the car, and so whatever that was attached to is probably trashed as well as whatever that is.
 

·
Registered
Maryland, USA
Joined
·
41 Posts
That's your parking brake cable. It probably became disconnected at the drum side and then with all that cable slack got wrapped up around the axle... Hopefully your CV joint is OK, I would think it probably is but that boot is likely toast...
 

·
Registered
Joined
·
9 Posts
Wow... Hopefully it looks worse than it is. Maybe it needs to go back to the shop that did your brake work. May not be related but its worth a try. I hope it works out well for you, please keep us updated.
 
1 - 5 of 5 Posts
Top