Nissan Armada & Infiniti QX56 Forums banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
1,707 Posts
Discussion Starter #1
hey guys...well i think it is time to change the in-cabin microfilter thingy, but what i wanted to know is...Do you really haveeee toooo?? It filters the air coming inside the 'Mada but will it be fine without changing it lol?
 

·
Premium Member
Joined
·
1,431 Posts
You'd be better off taking it out and not replacing it vs. leaving it in if it is really dirty. Leaving it in and it's substainally dirty will affect the quantity of air that can be drawn in.

I put a year on mine and it was pretty bad. The filters really do work, the amount of dust I get inside is very noticably less than any other vehicle I've onwed.
 

·
Premium Member
Joined
·
910 Posts
Did the group buy on the micro filters ever happen? Mine needs changing too. I've noticed it's pretty easy to tell when it's time- I get this sour smell on startup and then it goes away after a while on one filter.
 

·
Premium Member
Joined
·
248 Posts
adjmcloon said:
Did the group buy on the micro filters ever happen? Mine needs changing too. I've noticed it's pretty easy to tell when it's time- I get this sour smell on startup and then it goes away after a while on one filter.
I dont think thats the micro filter, that's the A/C. A lot of cars do that. There is some odor netralizer that you can buy at a parts store to make this go away. When I had my Murano, I changed my micro filter every 15K miles here in Las Vegas because of the high dust levels.
 

·
Premium Member
Joined
·
1,431 Posts
Yea the group buy came through....I got an extra set for next fall while I was at it. I think we had something like 50 sets of filters.
 

·
Premium Member
Joined
·
3,409 Posts
well, I feel that I need to bring this thread back to life after experiencing this mold type smell, does any one knows for sure if it is the Microfilter or the A/C?
it starts immedietly after starting the engine with the A/C off..
I am taking SCR advise taking the filter out, wash it, dry it, and put it back, but I don't know if this will take care of this smell problem. :confused: I will let you know :cool:
 

·
Premium Member
Joined
·
63 Posts
Don't mean to be stupid here, but where exactly is the filter located? I never really paid any attention to the filter, other than noticing it on the dealer sticker when I bought it.
 

·
Premium Member
Joined
·
1,431 Posts
jcvader99 said:
Don't mean to be stupid here, but where exactly is the filter located? I never really paid any attention to the filter, other than noticing it on the dealer sticker when I bought it.
You have to take out the glove box to get to it but thats where it's at.

I never paid attention to the wifes accord and didn't realize until recently that it had a cabin filter.....after 3 years it gets pretty nasty
 

·
Premium Member
Joined
·
3,409 Posts
ggeorgie said:
well, I feel that I need to bring this thread back to life after experiencing this mold type smell, does any one knows for sure if it is the Microfilter or the A/C?
it starts immedietly after starting the engine with the A/C off..
I am taking SCR advise taking the filter out, wash it, dry it, and put it back, but I don't know if this will take care of this smell problem. :confused: I will let you know :cool:
Actually, its not worth it, taking it out and cleaning it, since the manual states that its only need to be changed once a year or 15k, might as well pay the $40.00 and get it replaced. :cool:
 
1 - 9 of 9 Posts
Top