Nissan Armada & Infiniti QX56 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi I'm new here, glad to find a forum community for the new to me '08

yesterday i got only a click when i turned the key, tried a few more times and it started
then i cleaned the ignition switch and when i turned the key the starter would run for about a second, then just a click. engine did not fire. i reassembled the ignition switch again to make sure i had done it right, now it starts fine.

obviously i'm reaching to hear that its not the starter that is acting up. I don't want to replace it for obvious reasons due to its crazy location.

i will replace the ignition switch and the starter relay since they are cheaper and easier than the starter.

any ideas?
 

·
Super Moderator
Joined
·
5,819 Posts
hello.

i encourage you to do a search on start issues in this sub forum. lots of info.

let me ask, have you checked the obd port for any codes that may be present? if not, thats a good place to start.

things it could be:

-battery, battery cables, grounds straps
-starter solenoid
-camshaft sensor
-IPDM
-ECM
again there's a lot of info just in this first page of discussion on this.
 

·
Premium Member
Joined
·
57 Posts
Also check that fuse block that hangs from the positive battery post. Mine broke in half almost but still made contact most times. and then randomly i would have starting issues or no power at all unless i wiggled it around. Replaced from like $15 or something.
 

·
Premium Member
Joined
·
53 Posts
The random click at start could be something as simple as a ground. Sounds like you may have done something to enable the immobilizer when the starter spun but never started... normally its the simple things. Start there.

Sent from my SM-G960U using Tapatalk
 

·
Premium Member
Joined
·
23 Posts
Check the easy stuff as already recommended. Don't just throw parts at it. You can swap relays to test instead of buying new ones. Many options to check before you tackle the starter. However, I've got an '08 LE and had the same problem. Click, no crank, sometimes. I think there was a dead spot on the starter motor or something as it would start just fine 90% of the time.

Was scared to tear into the truck to replace the starter, so I put it off a year or so. By that time, it was 50% no crank. Turned out to not be too bad. There are some great tutorials out there. You just need a few common tools. Saved a ton of money versus paying for it to be replaced and only took me a few hours. I replaced the intake gaskets and spark plugs while I was in there with a lot of parts out of the way.

If you at all mechanically inclined and patient, you can do this starter replacement. Just don't try to take on the project if you've got a very limited time to get it replaced and back on the road as you'll rush it and are more likely to miss something or break something.
 
1 - 5 of 5 Posts
Top