Nissan Armada & Infiniti QX56 Forums banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
1,455 Posts
Discussion Starter #1
My load leveler is not activating? Just hooked up the car hauler with a M715 on it, about 7500 lbs. Safety chains were resting on the ground! Pulled forward a few feet and the rear end had raised about 4 inches about 6-8 inches lowere than usual? Cut on and off a couple of times to see if it would kick in, with and without the tow button in, no dice. Any one had this problem before???
James G.
 

·
Premium Member
Joined
·
5,215 Posts
How much tongue weight do you have? The air shocks can lift just so much. Once they reach maximum pressure the can't lift any more. The maximum tongue weight is 910 pounds, and any other load inside the Armada will lower the rear even more.
 

·
Premium Member
Joined
·
4,363 Posts
Tongue weight should be betweeen 5 and 10% of the trailer weight. Mine levels automatically, key in or not.
 

·
Premium Member
Joined
·
215 Posts
You do have Big Tow, right? I didn't see that in your signature. If no Big Tow, then no load leveling system.

But if you do have the system, as stated by another, it is automatic, whether you have key on or not. Might want to check to see if you have a blown fuse or something obvious before letting those SOB dealers get their hands on it.
 

·
Premium Member
Joined
·
3,582 Posts
Armada said:
You do have Big Tow, right? I didn't see that in your signature. If no Big Tow, then no load leveling system.

But if you do have the system, as stated by another, it is automatic, whether you have key on or not. Might want to check to see if you have a blown fuse or something obvious before letting those SOB dealers get their hands on it.
Mine does not work unless the key is turned on.

Keith
 

·
Premium Member
Joined
·
5,215 Posts
Do this check for the proper operation of the system:
1. Turn the key to "On", don't start engine.
2. The "CK SUSP" light on the instrument cluster should come on, then turn off after 2 seconds.
3.Check all the fuses associated with the system. There are 5 of them, identifed as #12, #29, #14, #19 and G. Look at attached drawings for their locations.
4. If everything checks OK and system still doesn't work properly you will have to go to your dealer.
 

Attachments

·
Premium Member
Joined
·
4,363 Posts
Armada said:
You do have Big Tow, right? I didn't see that in your signature. If no Big Tow, then no load leveling system.

But if you do have the system, as stated by another, it is automatic, whether you have key on or not. Might want to check to see if you have a blown fuse or something obvious before letting those SOB dealers get their hands on it.
Good point. I looked that the pick, saw the chrome grille and thought LE Big Tow. The leveling suspension isn't standard, it is part of the big tow pkg. If you don't know check to see if you have the tow button in center console and trans oil temp gauge. These come with the big tow. ;)
 

·
Premium Member
Joined
·
1,455 Posts
Discussion Starter #8
Big Tow

I do have the Big Tow package This load that I was hauling was the same thing I have been hauling for about a month. It has worked flawlessly for the last year and no problems until last Friday night. I have been using it a lot so I guess I may have blown a fuse. Thanks for all yalls help and I am going to call the dealer tomorrow and get it looked at as well as some other problems.
 

·
Premium Member
Joined
·
910 Posts
Well, did you hear the air pump come on? There's no mistaking when it kicks in. If not I'd say it's time to head to the dealer. Mine turns on when I have the key on and put some weight on the hitch.
 

·
Premium Member
Joined
·
1,455 Posts
Discussion Starter #10
adjmcloon said:
Well, did you hear the air pump come on? There's no mistaking when it kicks in. If not I'd say it's time to head to the dealer. Mine turns on when I have the key on and put some weight on the hitch.
Now it doesn't come on at all with anything on the hitch or on the inside it has worked fine until recently. The pump does not come on and The load I am hauling is only 7,500 pounds. We have had loads to almost the max before and no problem so I don't know what to think is wrong with it so I am calling the dealership tomorrow and tell them I need it fixed. Because The way the truck was squating down in the back I am afraid to drive it when my chains on the trailer hit the ground.
 

·
Premium Member
Joined
·
1,455 Posts
Discussion Starter #11
What?!

Well, I went to the dealership today and they told me that they had to order another compressor for the madas Load leveling! I only have 17,000 miles on the truck and the compresor is already out of commision. I am glad for it to still be under warranty and I don't have to pay but if it went out this quick it is going to suck wance my 36,000 mile warranty runs out. Well, I am hoping that I just got a defective one and this problem doesn't reocure.
 

·
Premium Member
Joined
·
4,363 Posts
Problem solved, and hopefully for good. ;)
 
1 - 12 of 12 Posts
Top