Nissan Armada & Infiniti QX56 Forums banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
48 Posts
Discussion Starter #1
Does anyone know what the manufacturing date was when the new rotors started to be used?
 

·
Premium Member
Joined
·
60 Posts
rp718 said:
Does anyone know what the manufacturing date was when the new rotors started to be used?
Based on the pictures seen on this forum I have new rotors on mine. It was built 7/05. I also have a tremendous amount of brake dust, so I am not convinced I have the new parts.
 

·
Premium Member
Joined
·
910 Posts
If you've got a lot of brake dust, you don't have the new parts. The "fix" includes new pads that have a different ratio of compounds and don't put off hardly any dust at all.
 

·
Premium Member
Joined
·
4,363 Posts
rp718 said:
Does anyone know what the manufacturing date was when the new rotors started to be used?
Some time in May '05. Not sure what day. ;)
 

·
Premium Member
Joined
·
23 Posts
rp718 said:
Does anyone know what the manufacturing date was when the new rotors started to be used?


I was at the dealer friday for my new 05 and was told that the latest info is late july build (i think he said the 28th) have the new brakes. Mine goes in tues, they are replacing most everything.
Terry
 

·
Premium Member
Joined
·
3 Posts
Interesting, I bought my Armada in June 2004 and they have not offered to replace my braking system, they just keep replacing rotors. I have had it in the shop 5 times in 1 year. Can anyone confirm that the '06 models have the new system?
 

·
Premium Member
Joined
·
23 Posts
I was told again today that after july 28th, different parts are being used. I am surprised that they have not offered you the kit. I had not trouble getting it. Also, if its been in the shop for the same thing 5 times, you shold be able to lemon law it. I saw 2 04,s in 2 days that were buybacks over this very brake issue. Maybe another dealer will be more helpful. Goodluck.
Terry
 
1 - 8 of 8 Posts
Top