Nissan Armada & Infiniti QX56 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Mods: I'm so sorry if this is not the correct thread

2012 armada SV
Is our No heat and new mystery sound related?
Video with sound, new sound with ignition off to on & on to off. Lasts the same duration each time and happens nearly every time for about 2 weeks now. We obviously haven't needed the heater(summertime here in Idaho) until this morning, it's not working, ambient temp air and a/c air working. Are these two things related?
TIA if you've got ideas or links for me to start my investigation! We don't mind the new noise, but we do need heat in about a month here in Idaho!
 

·
Administrator
Joined
·
6,638 Posts
that sound could be coming form anywhere. have you listened outside of the car? sounds like the compressor for the air bags.

did you open the engine room hood and listened in there to see if you can pinpoint the sound? maybe related or not, difficult to tell over the internet. i assume your car drives normally and there are no overheating issues correct? air blows cold? what about the dual zone, does that work as expected? if you dont have heat, its possible the heater core is the culprit. there is a valve that moves to change the coolant flow i believe and maybe this is causing the sound too?
 

·
Registered
Joined
·
3 Posts
Our 2014 just started doing that. It's most likely the mixing valve. It's located on the firewall on the passenger side. It has two hoses coming into it. If you have the hood up you'll likely hear this guy making the noise. ours is at the mechanics getting changed out. Hopefully that's what it was and were back in business with the heater.
Automotive tire Motor vehicle Coil Automotive design Automotive fuel system
 
1 - 4 of 4 Posts
Top