Nissan Armada & Infiniti QX56 Forums banner

21 - 40 of 52 Posts

·
Premium Member
Joined
·
2,685 Posts
80k

Fuel sending unit (warranty)
Window seal TSB (rattles)
Brakes
Tires
Shocks
Brakes
Tires (repeated intentionally)
Exhaust manifold
TSB on rear axel (special lube applied to stop clicking) out of pocket

Mostly wearing items.

Like my other nissans, the things that break are usually annoying rather than leave you stranded.



Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
704 Posts
102k....Aside from regular maintenance (oil, tranny, differential fluid, plugs, belt, brakes)...I've had to replace my radiator, stock front struts were leaking so replaced with Bilstein HD's, and front tie rods. Hearing some squeeks every now and then but other than that the mada runs great! The mada is garaged most of the time and only really take it out on the weekends and occasional weekend roadtrips. My 6 month old only rides in the mada because we feel safer with her.

With regular maintenance I'm hoping I can get this to 200K with no major breakdowns.
 

·
Premium Member
Joined
·
144 Posts
2005 Armada LE (3rd Owner) Blizzard white
147k Miles (I drive over 500 miles a week for work)
Header replacement (under extended warranty) it is now ticking again!!! DAMN IT!
TSB recalls fixed (was under 100k miles when i got it in 2011)
Front/Rear rotors and brakes replaced (Brakemotive PERFECT PERFORMANCE)
Rear Brake Calipers replaced (they were frozen. Not sure how it happened)
Replaced Transmission cooler line (DYI, dealer wanted $165 for this!!!)
Replaced main belt with GATES (a little shorter than stock. no more SQUEAL!!)

Things to do:
- Clicking when turning steering wheel (can be heard at steering column and outside of truck. Almost like AXLES clicking. SCARY!! Please someone chime in if you can help)
- Driver's side door sounds like it will open if I hit a hard bump while driving
- Front Shocks replacement (steering out of control when going over a bump!)
- Find all of the annoying rattles everywhere!!!
- Flush transmission
- Plug Replacement needed
- PAINT is needed BAD
- Want a Navigation BEZEL to add to mine
 

·
Premium Member
Joined
·
102 Posts
Not an Armada, but is it close enough? Saw this post and thought I'd add it from the QX56 forum.

2008 QX56 with 125K miles:

Sunroof drains stopped up - Fixed it myself with a piece of wire
Brake pedal cable out of adjustment - $100 at the Nissan dealer
Back up camera - $500 to replace at the Nissan dealer
Hood paint - ongoing

Four issues in 6 years isn't too bad IMHO. Of course, I would prefer no problems at all. I keep up my maintenance on it pretty well. I go with the Schedule 1 maintenance program. I've spent far more on maintenance than I have on repairs. Oh, I did have to install a new battery, wipers and tires! Those are consumables though. The plastic covers on the bumpers are not holding up well. Poor choice of material (UV problems). I'll probably look into having those replaced. Anyone done this on their Armadas?

Overall, a good vehicle. I just wish Infiniti had a better support structure. It's ridiculous that I couldn't take my Infiniti to a Nissan dealership for warranty work. And calling infiniti's 800 # for support is an absolute joke. All they do is refer you back to your dealership. Infiniti could take a major lesson from Chevrolet. Is Nissan any better in this area?
__________________
 

·
Premium Member
Joined
·
7 Posts
I have an '05 'mada LE that I just bought a couple months back (2nd owner). Got it with 88K on it, now has 92K. Got it for cheap, ESPECIALLY when compared to like American models in this area. Only thing my LE doesn't have is DVD player, but looking to add to that.

Not sure of everything done previously, but looks like I have a front differential that is leaking fluid. Not too excited about that. I'm by no means a mechanic or real knowledgable about cars, although I enjoy learning. Is it safe to say that I should let a real mechanic give this a go? This prob isn't a DYI type of project.

Oh, and I also was having issues filling my car with gas. Took it to the local O'Reilly Autoparts and had them run the diagnostics. After some research I found I could just replace the EVAP Control Sensor solenoid valve. So I saved some money and did that one myself. My driver's side rearview mirror just cracked too. :-/ Cold weather (-15ºF), turned on the rear defrost (also controls the mirror defrost which is annoying) and it ended up cracking from top to bottom. Gotta get that replaced soon. Other than that, I love my truck!! :)
 

·
Premium Member
Joined
·
62 Posts
tale of the tape.....

Time to chime in.............. 04 bought as new , still going strong after 156k , outside of all the custom changes.....

Radiator, struts, power steering pump, new rack n pin steering, multiple front rotors, rear wheel hubs....

thats about it for major stuff, tranny flush done at dealer, all fluids and belts done by me, new plugs , cai and throttle body, flowmaster exhaust system..(now it sounds like a V8)

knock on wood she makes it another 156k, !!
 

·
Premium Member
Joined
·
144 Posts
Time to chime in.............. 04 bought as new , still going strong after 156k , outside of all the custom changes.....

Radiator, struts, power steering pump, new rack n pin steering, multiple front rotors, rear wheel hubs....

thats about it for major stuff, tranny flush done at dealer, all fluids and belts done by me, new plugs , cai and throttle body, flowmaster exhaust system..(now it sounds like a V8)

knock on wood she makes it another 156k, !!
Congrats. I just hit 153k. I see you replaces rack and pinion. Was your steering wheel clicking too? I was told I needed steering wheel shaft knuckle please let me know what all you need


Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
40 Posts
Had mine since 06, 95k miles, not too many issues. Had to fight dealer w/ brake booster issue, high pressure power steering hose replaced due to leak, currently on 3rd set of tires and rotors, but should be good now w/Michelins and wagner rotors. I did replace the front shocks w/bilsteins but the factory were still good. 2nd battery. It runs as good now as it did new.
Might need to change radiator, have a slooooow leak that I cant find.
 

·
Premium Member
Joined
·
704 Posts
Getting close to 107K. Only major repair so far since I took ownership was the radiator at around 100K. Other than that just regular maintenance.
 

·
Premium Member
Joined
·
89 Posts
05 LE with 112,000 miles. Replaced cracked exhaust manifolds, front wheel bearings. Replacing front shocks with Bilsteins tomorrow.
 

·
Premium Member
Joined
·
300 Posts
My 05 has 120 k on it. Love it. Needs a o2 sensor and oil gauge sensor. Does this seem to be typical?
I've replaced both these sensors too. Not sure if it is all that common. Both sensors are easy to change if you rent the proper tools from the auto part store. I paid $120.00 for the o2 sensor, and $16.00 for the oil pressure sensor.
 

·
Premium Member
Joined
·
97 Posts
2008 Le with 110k 2 yrs we have owned in I replaced the cracked manifolds under warranty when I bought it and a battery other than that I have had no issues at all-read the other day that these Armada's are not reliable but I have not had anything (knock on wood)major needed we started full synthetic when we bought it and just dropped some BG cleaner in last time we changed the oil it's doing great and hence my mileage I use it daily and It gets us out of town on the weekends Great Nissan!
 

·
Premium Member
Joined
·
3 Posts
2007 205,000 miles. 4 Wheel Bearings, Front diff gear box seal. ABS, VDC OFF, SLIP, And 4 Wheel Drive lights are all on trying figure out.
 

·
Premium Member
Joined
·
3,332 Posts
04, 136k miles. I am the second owner. Got it at 35K miles... Nothing major (except tranny running hot now while stop n go traffic or mtn climbing. Still trying to diagnose) would say. Im lucky I guess. No crack manifold, cat still good. The only thing I changed are the oil, tranny oil, front n rear diff. O I did have a leak in the transfer case seal but was fixed. Radiator is a couple of yrs old since FAV decided to punch a landrover n landrover hit a cop car. Lol...my serpentine belt is still original, sparks also (they r on my to do list) but they seems to be working fine.

Things I done to it cuz I wanted to: front shocks changed to bilstien then to radflo coilovers, 6" lift, 325/65 18 tires, r1 concept front n rear brakes. Ebc pads both green n yellow (don't recommend them). S&b air intake. HID headlights and fogs. All LED interior. All murder out, no chrome any where.

sent from broken autoguide app.
 

·
Premium Member
Joined
·
4 Posts
Have an '04 that I am very pleased with. our family is second owner from very low mileage. I drive it every day and have over 214,000 miles so far. planning on 300,000. I am positive its still on original plugs and wires. Going to change soon. Always running synthetic oil and replacing filter. I use this as a truck; pull work trailer,strap ladders and lumber on the roof rack and pack up the inside. New England winter with salt is showing its affects on the underside sad to say.
 

·
Premium Member
Joined
·
3 Posts
Just dropped off vehicle at dealership still have VDC OFF, SLIP,ABS,4WD light's all on. Already changed 1 speed sensor..More to come !!!
 

·
Premium Member
Joined
·
3 Posts
Picked vehicle up from dealership..Good to go. $120 to diagnose and repair. Found partially broken wire to one of the speed sensors.
 
21 - 40 of 52 Posts
Top