Nissan Armada & Infiniti QX56 Forums banner
1 - 4 of 4 Posts

·
Banned
Joined
·
346 Posts
Discussion Starter · #1 ·
Heya everyone, got a question and hope someone can answer here. I bought my Mada with a Lo-Jack and my occupation always has me away from my ride. Sometimes I go out a few months and I have my roomate start her up once a week. Lo-Jack sez you need to have it started at least once a week and the battery always needs to be connected. Is this BS?? Can I just disconnect the battery without the worries of the device not working properly when hooked back up?? :D
 

·
Premium Member
Joined
·
5,214 Posts
The Armada should be started about once a week even if you don't have Lo-Jack. This circulates oil through the engine and trnsmission, coating surfaces to protect the metal. Also it rids the engine of moisture that has condensed inside. The engine should be run for several minutes each week, until it is up to temp.
 

·
Premium Member
Joined
·
603 Posts
I have Lo-Jack installed on my 02 Acural TLS but not on my MADA. I don't believe Lo-Jack draws that much "juice" from the battery. So, as long as your battery condition is good, you could leave the vehicle for 2 weeks without having any issue. I left my Acura for more than 2 weeks in the garage while I was on vacation and everything seems to be just fine when I came back. I did not hear Lo-Jack complain at all.

Besides, the tech guy that installed the Lo-Jack told me the device itself has its own backup battery pack. So, even the main batter was disconnected (while the transmission was replaced at the dealer), the device has its own power to operate.

Just my $0.02.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top