Nissan Armada & Infiniti QX56 Forums banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
15 Posts
Discussion Starter · #1 ·
I'm having a hard time trying to diagnose the problem with my 07 Armada liftgate. It will open from the button on the dash or keyfob button. But will not close for some reason. I have pulled the interior panels to see if I find anything out of the ordinary but I haven't.

If button on the dash is pushed to close it,I get the 3 beeps but nothing happens. The rear close/cancel isn't working at all as well. I've tried disconnecting the close/cancel switch. But that didn't change anything.

The only thing I'm almost positive is not normal is while the liftgate is opening,I hear and see (since I have the interior panel off) the latch mechanism cycle as it gets to the fully open position. I'm leaning toward the latch mechanism or possibly the close/cancel switch itself. Any advice would be appreciated. Thanks
 

·
Premium Member
Joined
·
15 Posts
Discussion Starter · #2 ·
So I did some more troubleshooting today.The liftgate opened like I originally posted. But after its in the open position. The system thinks the liftgate is closed and tries to push the liftgate open even further. Does anyone know if there is a open/closed position sensor that may be causing this to happen?
 

·
Premium Member
Joined
·
15 Posts
Discussion Starter · #3 ·
My problem has been solved. It was the latch assembly. Hopefully this will be helpful for someone that may have the same problem.
 

·
Registered
Joined
·
4 Posts
I am having what I think is the identical problem to yours. Something that I have noticed is that when I start the opening process and listen to the latch mechanism it makes a sound like it is being actuated 3 times in a row then pauses and actuates a final time. When I apply resistance to the door while it is trying to open, it makes no attempt to use the motor to draw it back closed again. What did you discover about the latch that helped you be certain that the assembly was the problem? Did you replace or repair the assembly to fix your situation? Thank you!
 

·
Premium Member
Joined
·
2,692 Posts
My problem has been solved. It was the latch assembly. Hopefully this will be helpful for someone that may have the same problem.
Do you mean the latch assembly with the motor that locks/unlocks via the handle and the keyfob or the actual handle?

I just noticed my motor is trying to push the door open when I try to close it from the fob. The rear Close/Cancel button doesn't work either.

The latch mechanism does actuate and I lubed it up but no luck.
 

·
Premium Member
Joined
·
2,692 Posts
Replacing the latch assembly worked for me in resolving all my tailgate problems.

Thanks for the quick reply. To confirm, it is it this part?

Edit: This is the part that sits in the rear hatch door and has 3 bolts on the bottom and one on the top and has a motor which latches onto the latch.

It's ~$300 so want to make sure before I purchase.


 

·
Premium Member
Joined
·
2,692 Posts
Here is a link to a cheaper one on eBay. I’d never pay Nissan prices if I can help it. INFINITI QX56 REAR LIFT GATE HATCH TRUNK LATCH LOCK ACTUATOR OEM (04_10) | eBay
thanks for the link! I do have a concern with used parts though. Did you get a used one?

I also saw the same part number listed for the infinity qx but it said you have to program it with consult (dealer).

I remember once my lift gate would not work and the dealer had to program. Is there any issues using an Infiniti part?

Today I also addressed a major leak on the hatch. I had my gf spray water and it was gushing in below the window. I took off the weather stripping and cleaned it and it seems to have stopped.

I don’t like to be cheap but the Armada only gets like 6000 miles a year (second car) and it’s only worth ~$3k according to online sales :(
 

·
Registered
Joined
·
4 Posts
I have a qx56 but my understanding is that they are the same exact part. I did purchase used and saved a ton doing that. The part works great and I’ve had no problems since. My vehicle value and yours being the same I saw no sense in sinking dollars in it that can’t be recovered from selling it. I have the same problem with water in the tailgate you have seen. Thanks for the tip, that is on my next repair list.
 

·
Premium Member
Joined
·
2,692 Posts
Thanks for confirming. I suspect my leaky door and window seals may have allowed water in it to mess it up. I cleaned both and will see if they are water tight now. Window seems ok but still need to test the door as I was getting a small drip.

Interestingly, it worked fine today 10 times in a row the.n randomly beeped while open 20 minutes later and failed to work.

strange issue

Ordered the part - will hopefully be in by the weekend and I will report back results.

Fixed! I was able to find a new latch motor/actuator on eBay for pretty cheap. Installed it tonight and the lift gate is opening and closing properly.

My theory is that the leaky window seal shorted something out in the previous.

Thanks again for your assistance!!
 
1 - 12 of 12 Posts
Top