Nissan Armada & Infiniti QX56 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello All,
With no load, I notice the air compressor turning on and raising the rear when starting the truck. When I shut it off, it drops about 2 inches after an hour. I’m assuming that’s not normal and I have a leak. 2017 with 87k. Any thoughts?
 

·
Premium Member
Joined
·
169 Posts
Yup, you got a leak...not uncommon with air systems after a while. The springs are intentionally soft enough that the Armada will sag some when the shocks loose air. You can chase down the leak and repair/replace the parts. Or like many of us with the previous generation like to do, delete the whole air system...not sure how common that is with the newer Gen yet?
 

·
Premium Member
Joined
·
1,651 Posts
At the moment, there isn’t a single, reliable option for the Z62 QX56/80 and Y62 armada in regards to deleting the rear air leveling system.

Just to rule out any leaks at the air lines and their connection points, make a soap + water solution. Spray around the lines where it connects to the shocks and air leveling compressor. If no leaks are found, it could be the compressor itself or the height leveling sensor. A full range scan tool can easily read the DTC for this issue; a pocket scanner can’t.
 

·
Premium Member
Joined
·
1,651 Posts
Thank you

Dealer “comfirmrd” compressor had a leak. Had them repair it. Got it home and looks like it’s still sagging about an inch. Guess they’ll want to throw more parts at it.
Did the dealership replace the compressor? If so, they should've done a reset/relearn procedure after installing a new compressor.
 
1 - 6 of 6 Posts
Top