Nissan Armada & Infiniti QX56 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I got my 19 Armada SL 4x4 in August 2020 with 39k miles. A day after we drove it off the lot it wouldn't start on us twice after going to the grocery store. Battery was replaced and problem solved. Fast forward to the beginning of the week it wouldn't start so I jumped it and drove to home and put it on the trickle charger overnight. It started and the wife drove it a a few places and came home and it wouldn't start again. Took it to the Infiniti dealer cause they've given me better service than Nissan. Needless to say it sat up there 3 days and they're telling me there's a recall on some 2nd gens and for the ECM to be reprogrammed cause it's not sending enough voltage or something to start it. The service advisor said the recall should fix the issue but everything is telling me the alternator is bad if the battery is draining after light use. Well I took it to the Nissan dealer last night since Infiniti could perform the recall cause they don't have Nissan software. He also told me some qx80s are having the same recall as well. Regardless the recall should be done today and I'll put up an update if the recall fixes the issue or not. Sorry if this sounded like a rant but it's been an interesting process...
 

·
Premium Member
2013 Armada Platinum 8 passenger
Joined
·
62 Posts
Sounds fishy. Infiniti has everything needed to do this. The software is the same.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Sounds fishy. Infiniti has everything needed to do this. The software is the same.
When I picked it up my service advisor said it had a recall and it should fix my issue. I asked why he couldn't do it and he said they didn't have Nissan software which confused me. I was already pretty pissed that they had it 3 days and they didn't call or text me with that update. I had to drive up there just to get the status. After he told me they didn't have the software he waived the diagnosis fee so I felt he was trying to somewhat be nice about it.

UPDATE:
Picked it up a few hours ago and started with no issues. I let it run for a while in the lot and it idled down faster and lower than it has been which use a plus. Since we've had it it seemed to idle high and it seemed to shift late sometimes but we had it looked at and the same dealer said there wasn't anything wrong with it. But after this issue I think I'm going to have the Nissan dealer from a different dealer group service it... If there's any other issues I'll be sure to post another update in a few days if has a problem starting again.
 

·
Premium Member
Joined
·
20 Posts
I got my 19 Armada SL 4x4 in August 2020 with 39k miles. A day after we drove it off the lot it wouldn't start on us twice after going to the grocery store. Battery was replaced and problem solved. Fast forward to the beginning of the week it wouldn't start so I jumped it and drove to home and put it on the trickle charger overnight. It started and the wife drove it a a few places and came home and it wouldn't start again. Took it to the Infiniti dealer cause they've given me better service than Nissan. Needless to say it sat up there 3 days and they're telling me there's a recall on some 2nd gens and for the ECM to be reprogrammed cause it's not sending enough voltage or something to start it. The service advisor said the recall should fix the issue but everything is telling me the alternator is bad if the battery is draining after light use. Well I took it to the Nissan dealer last night since Infiniti could perform the recall cause they don't have Nissan software. He also told me some qx80s are having the same recall as well. Regardless the recall should be done today and I'll put up an update if the recall fixes the issue or not. Sorry if this sounded like a rant but it's been an interesting process...
old news, they (factory) dont regulate the battery voltage, the factory controls the CHARGE, a failure in design. I unplugged the current sensor at the battery negative terminal and never looked back, battery is always charged running 14.3 to 13.9 volts, just saying.
 

·
Premium Member
Joined
·
22 Posts
I got my 19 Armada SL 4x4 in August 2020 with 39k miles. A day after we drove it off the lot it wouldn't start on us twice after going to the grocery store. Battery was replaced and problem solved. Fast forward to the beginning of the week it wouldn't start so I jumped it and drove to home and put it on the trickle charger overnight. It started and the wife drove it a a few places and came home and it wouldn't start again. Took it to the Infiniti dealer cause they've given me better service than Nissan. Needless to say it sat up there 3 days and they're telling me there's a recall on some 2nd gens and for the ECM to be reprogrammed cause it's not sending enough voltage or something to start it. The service advisor said the recall should fix the issue but everything is telling me the alternator is bad if the battery is draining after light use. Well I took it to the Nissan dealer last night since Infiniti could perform the recall cause they don't have Nissan software. He also told me some qx80s are having the same recall as well. Regardless the recall should be done today and I'll put up an update if the recall fixes the issue or not. Sorry if this sounded like a rant but it's been an interesting process...
This sounds like the "no-start" issue many have had. There is a TSB that reprograms the ECM/ECU and replaces the brake sensor (vehicle doesn't sense your foot on the brake pedal and randomly won't start). Happened with my 2019. It was a quick fix at the dealer. Just FYI, good luck!
 

·
Registered
Joined
·
1 Posts
I got my 19 Armada SL 4x4 in August 2020 with 39k miles. A day after we drove it off the lot it wouldn't start on us twice after going to the grocery store. Battery was replaced and problem solved. Fast forward to the beginning of the week it wouldn't start so I jumped it and drove to home and put it on the trickle charger overnight. It started and the wife drove it a a few places and came home and it wouldn't start again. Took it to the Infiniti dealer cause they've given me better service than Nissan. Needless to say it sat up there 3 days and they're telling me there's a recall on some 2nd gens and for the ECM to be reprogrammed cause it's not sending enough voltage or something to start it. The service advisor said the recall should fix the issue but everything is telling me the alternator is bad if the battery is draining after light use. Well I took it to the Nissan dealer last night since Infiniti could perform the recall cause they don't have Nissan software. He also told me some qx80s are having the same recall as well. Regardless the recall should be done today and I'll put up an update if the recall fixes the issue or not. Sorry if this sounded like a rant but it's been an interesting process...
hi don’t waste your money. Go buy a new battery and put in. I had same problems and bought a new battery. I took it to Nissan twice and couldn’t find the problem. One technician later told me after work to get a new battery. I have had mine since0 mileage 2017. At one point I was trading it in for GX , but I drove the GX and didn’t have the power I wanted. Then I gave up. Just get a new battery from sam’s club and u will not have any problems

good luck

GB


I got my 19 Armada SL 4x4 in August 2020 with 39k miles. A day after we drove it off the lot it wouldn't start on us twice after going to the grocery store. Battery was replaced and problem solved. Fast forward to the beginning of the week it wouldn't start so I jumped it and drove to home and put it on the trickle charger overnight. It started and the wife drove it a a few places and came home and it wouldn't start again. Took it to the Infiniti dealer cause they've given me better service than Nissan. Needless to say it sat up there 3 days and they're telling me there's a recall on some 2nd gens and for the ECM to be reprogrammed cause it's not sending enough voltage or something to start it. The service advisor said the recall should fix the issue but everything is telling me the alternator is bad if the battery is draining after light use. Well I took it to the Nissan dealer last night since Infiniti could perform the recall cause they don't have Nissan software. He also told me some qx80s are having the same recall as well. Regardless the recall should be done today and I'll put up an update if the recall fixes the issue or not. Sorry if this sounded like a rant but it's been an interesting process...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Thanks guys. The ECM reprogram actually worked for me though. It hasn't died yet and it seems to be idling lower now which was bothering me cause it idled at 1-1200 ish rpm before. I took it to the dealer for that and possibly shift problems but they said it was normal. After the reprogram it now idles around 7-800rpm and seems to shift better.

@Msk I wish a new battery would've solved it but I had a new battery put in when we bought it in August 2020 so the battery was good. I did just get a new battery from Sam's for my Chevy and I like it. Probably the best price dual post you can find
 
1 - 9 of 9 Posts
Top