Nissan Armada & Infiniti QX56 Forums banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
497 Posts
Discussion Starter #1
Haven't seen any threads on this one. Just got my ride a couple weeks ago. I have factory installed Sirius Satellite. Neither I or the dealer has been able to pick up a signal to activate the system. My sales guy thinks it is antenna location, which has been moved inside the cabin next to the rearview for asthetics. I think it used to be on the outside on the windshield (looked ugly). Service department ordered a new antenna and they are supposed to call me when it comes in. However, the sales guy is offering to have an external, aftermarket (BMWish) sharkfin antenna put on at the local radio install place on their dime. There are no drill holes or anything like that, just magnetics and no lost wires going through a crack in the window. Sounds like a plan to me. All I asked is that if they could paint it to match the truck. Anyone else have Satellite Radio issues for their '05
 

·
Premium Member
Joined
·
497 Posts
Discussion Starter #2
Can't believe it's just me

Am I the only one who has an '05 with Satellite (with problems). If you have a Satellite '04 or '05, I want to know where your antenna is located (inside/outside, windshield/roof, etc.) Dealer says they are waiting on authorization from Nissan to pay for aftermarket antenna. :usuck:
 

·
Premium Member
Joined
·
13 Posts
FL_Crushin said:
Am I the only one who has an '05 with Satellite (with problems). If you have a Satellite '04 or '05, I want to know where your antenna is located (inside/outside, windshield/roof, etc.) Dealer says they are waiting on authorization from Nissan to pay for aftermarket antenna. :usuck:
I have the factory Sirius in my '04. I purchased the radio from grubbs and installed it myself. I did not use the two wire antenna that came with the unit as the wires were only about 15' long and I could not buy a two wire extension cable. I bought another antenna (single wire, magnetic mount) and put it on the center of the roof just forward of the 3rd brake light. I ran the wire under the weatherstrip, inside the trim and forward to the factory location. I also had to purchase a extension cable and one to two wire adapter. Everything works great.
 

·
Premium Member
Joined
·
4,363 Posts
FL_Crushin said:
Haven't seen any threads on this one. Just got my ride a couple weeks ago. I have factory installed Sirius Satellite. Neither I or the dealer has been able to pick up a signal to activate the system. My sales guy thinks it is antenna location, which has been moved inside the cabin next to the rearview for asthetics. I think it used to be on the outside on the windshield (looked ugly). Service department ordered a new antenna and they are supposed to call me when it comes in. However, the sales guy is offering to have an external, aftermarket (BMWish) sharkfin antenna put on at the local radio install place on their dime. There are no drill holes or anything like that, just magnetics and no lost wires going through a crack in the window. Sounds like a plan to me. All I asked is that if they could paint it to match the truck. Anyone else have Satellite Radio issues for their '05
I don't have it, only option I didn't get, but I i'm pretty sure the antenna should be outside, not inside. The windshield has metalic tint in it that can block signals. You shouldn't mount your radar that high either. The optial place for the antenna would be a pod mounted on the roof just above the tailgate. I don't know if this is spec for the armada though but I would tell the dealer to put it there. If he can't get money for the antenna or antenna extension, pick one up from the store and give it to him to install. Better to have it done correct than hate it for years to come.
https://www.1stnissanparts.com/index.php/cPath/122_127_133?osCsid=8720141adb85f652c7b6d87609f8c4a1
 

·
Premium Member
Joined
·
96 Posts
I have the factory Sirius. The antenae is just to the right of the rear view mirror, inside the glass. It works well on open roads, but drops out quite a bit when we hit backroads and the trees start to loom over the road. Good luck with your issue, I hope the antenae is the answer for you :(
 

·
Premium Member
Joined
·
4,363 Posts
blackrain said:
I have the factory Sirius. The antenae is just to the right of the rear view mirror, inside the glass. It works well on open roads, but drops out quite a bit when we hit backroads and the trees start to loom over the road. Good luck with your issue, I hope the antenae is the answer for you :(
In the glass. That makes sense. The FM/AM antennas are there also. The glass would be made to allow the signal to travel through. Wonder if all Armadas or all LE, etc. have the antenna even if they don't have the satelite radio. Sometimes they do that and you just need to add the module, the wiring is there already. EX. My Bose has SAT button on it. :confused:
 

·
Premium Member
Joined
·
497 Posts
Discussion Starter #7
Antenna Location

blackrain said:
I have the factory Sirius. The antenae is just to the right of the rear view mirror, inside the glass. It works well on open roads, but drops out quite a bit when we hit backroads and the trees start to loom over the road. Good luck with your issue, I hope the antenae is the answer for you :(
Mine is in the same place just right on top of that metalic visor that is on the windshield. I'm sure that can't be ideal. Apparently, they do work their but may not be the best location. The Nissan rep will be here on Tuesday to check it out for me and propose a solution.
 

·
Premium Member
Joined
·
497 Posts
Discussion Starter #8
Sat Antenna

92TripleBlack said:
In the glass. That makes sense. The FM/AM antennas are there also. The glass would be made to allow the signal to travel through. Wonder if all Armadas or all LE, etc. have the antenna even if they don't have the satelite radio. Sometimes they do that and you just need to add the module, the wiring is there already. EX. My Bose has SAT button on it. :confused:
It's not actually "in" the glass. It's a big triangular antenna mounted on the "inside" of the glass just to the right of the rearview on top of that metallic tape. This is definately and added unit (not standard). I would prefer it to be where you said. I'm sure the reception would be better. Hopefully I can get a nice one and get it color matched to the truck.
 

·
Premium Member
Joined
·
4,363 Posts

·
Premium Member
Joined
·
497 Posts
Discussion Starter #10
1 - 10 of 10 Posts
Top