Nissan Armada & Infiniti QX56 Forums banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
1,431 Posts
Discussion Starter #1
So after nearly a year of ownership (it'll be a year 4/5) I thought I had all the rattles, and defects fixed. After many months of complaining that the passenger airbag sensor won't enable when my wife sits in it Nissan agreed to replace the sensor. This was after she had to sit in 7 different Armadas and verified that everyone functioned by turning off the light and mine didn't. So anyway the parts came in and I left it at the dealership all day. When I picked it up the manager told me he hoped this fixed it but he had a fear it didn't as he had a "light" coworker sit in the seat and it didn't go off. I'm thinking whats the odds of getting two faulty seats in a row? I mean we tested 7 random armadas and they all worked? So when my wife gets home we go out and [email protected]#$! same crap as before but get this, I sit my fat A$$ in it and it won't detect me either and I'm 180+ (I quit stepping on the scale once I hit 180). It works if I don't put any weight on the arm rest but were talking it needs at least 150lbs to shut the light off :censor:

Well I think we will just go sit in another armada and tell them we want that specific seat.
 

·
Premium Member
Joined
·
910 Posts
Dude! That's gotta suck! I'm glad to hear you're rattle free.. I'm pretty much there too- just gotta get that window TSB done to killl the passenger window. Check this out- my "permanent brake fix" turned out to be horsesh!t. My rotors are warped again after 2k miles! So I guess the good side is that I have Nissan by the short hairs due to my lemon law claim. The last time in the shop (3 weeks!) was their "good faith" opportunity and I have the certified letter receipt tucked away. I think I'm going to try to get them to cut me a check for $2k and just go buy the Stillen kit. I doubt they'll go for it, though.

So hey man, do you suppose they just didn't replace the sensor? I've had my dealer pull that- they claim to do the work (and bill Nissan) and then don't do shi!t....
 

·
Premium Member
Joined
·
98 Posts
Have they checked the wiring harness? Perhaps it a fault in the wiring harness causing it rather than the seat/sensor itself?

-mike
 

·
Premium Member
Joined
·
1,431 Posts
Discussion Starter #4
You can tell the seat bottom is new, plus it worse than it was with the old seat so I'm sure they did it. They've supposedly hooked up and their pc says everything is functioning correctly back when I first had the problem? Who knows, I'll give them another shot at switching it out with one that we sit in first.

Adjmcloon that sucks, and you've tricked out your armada so much that I'm sure you don't want to trade out for an 05 or 06, and have to start over. Even if they made the deal sweet I'm sure it wouldn't cover your upgrade cost. I had them check my brakes yesterday when it was in and they said it was still holding up. I had them turned and TSB'd at 6000 miles and I'm at 9k now. I'm not in a big hurry to get the real fix as I'm not having to go in every other week for them. I figure if Nissan kicks up the brake warranty to 36k/3yr I can stretch the old brakes out for a while and then get the new brakes and not have to pay for brakes a year or two beyond what I would have had to anyway.
 

·
Premium Member
Joined
·
1,431 Posts
Discussion Starter #6
It just a fix for a known problem. Most of them are warranty type issues but some aren't. For example the Titan has a TSB to use different oil in the rear differential, but its not covered by warranty to replace it.
 

·
Premium Member
Joined
·
15 Posts
llajumpvid said:
It just a fix for a known problem. Most of them are warranty type issues but some aren't. For example the Titan has a TSB to use different oil in the rear differential, but its not covered by warranty to replace it.

Ok Got Thanks a lot
 
1 - 7 of 7 Posts
Top