Nissan Armada & Infiniti QX56 Forums banner
1 - 20 of 39 Posts

·
Premium Member
Joined
·
120 Posts
Discussion Starter · #1 ·
I have noticed with the colder weather that over certain bumps such as speed bumps that really extend the suspension it is causing squeeking. Sounds like a 10 year old ride opposed to 2. Anyone else having this happen, and is it normal?
 

·
Premium Member
Joined
·
1,431 Posts
cfranzen said:
I have noticed with the colder weather that over certain bumps such as speed bumps that really extend the suspension it is causing squeeking. Sounds like a 10 year old ride opposed to 2. Anyone else having this happen, and is it normal?
Don't know if it's normal but mine does the same thing going over speed bumps when the temp is below about 50F.
 

·
Premium Member
Joined
·
22 Posts
I get what could be considered "squeaking" from the front suspension. Mine was not temp related though. I haven't fixed it yet, but I believe that the problem is coming from the radiator cap rubbing against the hood.

I figured this out one day when I was shutting the door to the Armada and heard the squeak. I told my wife to shut the door a couple of times so I could troubleshoot. I had her shut the door while I had my hand on the hood and it did NOT make the squeak. I then placed a shop towel over the radiator cap. It was just draped over so it wasn't double folded. She closed the door again and the squeak did NOT occur. I'm going to have Nissan fix it since there's still quite a few rattles in the interior that need to be fixed.

Hope it's just this simple...

Also found this on pg5 of the The Armada Squeak and Rattle Thread

Dealer fixed one that was really annoying. Squeak coming from front end once car was warmed up. Radiator cap was rubbing against hood.

Gotta love the internet!
 

·
Premium Member
Joined
·
37 Posts
Mine is worse in the cold. Dealer has ordered new sway rod bushings, says a TSB is coming out on this issue
 

·
Premium Member
Joined
·
57 Posts
I just brought my QX in for the same issue and it ended up being the front sway bar bushings.
 

·
Premium Member
Joined
·
213 Posts
Gotta love the cold weather:

Just got back from the dealer for $9 fix for the same squeak over bumps on the 05 mada. They lubricated the sway bar bushings. It still makes noise!!! Is there a TSB on this yet?

The dealer also tried to fix the window creak by tightening the window regulator. Still creaks. I will have to find and print the TSB for them.

They also tried to fix the passenger door latch with is still frozen. The wife was driving the car earlier this week and the door came open while she was driving. Not a good thing. Apparently the door latch was frozen and the door was not shut but appeared to be shut. Luckily nothing was damaged. TSB also will have to print.

Guess we will have to try again.... Gotta love this forum for finding help!!!!
 

·
SHIFT_Moderator
Joined
·
12,985 Posts
When I had the problem, it was guaranteed to start after a weekend of offroad driving so I would guess that it's probably more noticeable this time of the year with the Road Salt building up on the undercarriage. Sometimes, I was able to get away with just spraying the crud out of the bushings with the high pressure rinse sprayer from the car wash (no soap). That might get you by until you have time to schedule it in.
 

·
SHIFT_Moderator
Joined
·
12,985 Posts
ggeorgie said:
I've never had this problem yet, and am at 36500 miles, but then again am in So. Cali, no salt, and 4 wheeling. :D
Well then, we just need to get you down here and show you just how good these trucks really are and where they put even the best Chevy to shame. :D :D
 
1 - 20 of 39 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top