Nissan Armada & Infiniti QX56 Forums banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
5 Posts
Discussion Starter #1
Well as you all know, I just recently purchase my DWB 05 Armada.

Anyhow, On the way to work this morning. I knoticed at around 70 mph if I let go of the steering wheel. I get a jitter from the steering, but then when I accelerate to 80 mph and let go of the wheel ..the jittering goes away.

Any of you have this problem?

Am I just a new owner who is over reacting and being to anal?

if not, please tell me what I should do..

Thanks again

-Eric
 

·
Premium Member
Joined
·
5,215 Posts
You need to get a Road Force Balance on your wheels. Ask your dealer to take care of it.
 

·
Premium Member
Joined
·
220 Posts
This has been due to the stock tires. They are sh#@. I took mine to discount tire, paid $60 and had them road force balanced. This fixed the problem, but one tire is so bad that the shimmy is still there if the tire is on the front (but it is not as bad as it was). I can't wait to get new tires.
 

·
Premium Member
Joined
·
5 Posts
Discussion Starter #4
AZARMADA said:
This has been due to the stock tires. They are sh#@. I took mine to discount tire, paid $60 and had them road force balanced. This fixed the problem, but one tire is so bad that the shimmy is still there if the tire is on the front (but it is not as bad as it was). I can't wait to get new tires.

Thanks guys,

Do you know if the dealer is gonna charge me for this?

Considering Ive only had it for a week :confused:
 

·
Premium Member
Joined
·
5,215 Posts
I would insist that it be free!
 
1 - 7 of 7 Posts
Top