Nissan Armada & Infiniti QX56 Forums banner

1 - 15 of 15 Posts

·
Premium Member
Joined
·
1,707 Posts
we use to have a suspension squeek type of noise coming from the front...we took it to the dealer and he said it might have been caused b/c of a car wash (water) and the water froze (it was winter) and that's the cause of the suspension squeek from the front...pretty sure the dealer was lying b/c the squeek barely went away...the squeek only happened when it was really cold though...just go and ask ur dealer
 

·
Premium Member
Joined
·
60 Posts
fstrom said:
Does anyone elses suspension creak or squeek?



Have it in the winter...not summer months. dealer said its the urethane suspension parts in the "dry" colorado climate. Whatever!!!!! He said try to use silicone lubricant on the urethane stuff.
 

·
Premium Member
Joined
·
4,363 Posts
fstrom said:
Does anyone elses suspension creak or squeek?
From where? I had a squeek from the rear. Turns out there was a TSB on the rear hubs needing greasing. No more squeek. :D
 

·
Premium Member
Joined
·
60 Posts
92TripleBlack said:
From where? I had a squeek from the rear. Turns out there was a TSB on the rear hubs needing greasing. No more squeek. :D


Mine comes from the front for sure. Haven't heard it since the spring. Usually detected going slow with the windows down over speed bumps in parking lots, especially when crossing them at a slight angle.
 

·
Premium Member
Joined
·
4,363 Posts
Mine was different. Like a metal clink ting noise that happened when you started applying gas from a complete stop.
 

·
Premium Member
Joined
·
1,707 Posts
mess said:
Mine comes from the front for sure. Haven't heard it since the spring. Usually detected going slow with the windows down over speed bumps in parking lots, especially when crossing them at a slight angle.
excatly same with mine..only in winter though
 

·
Premium Member
Joined
·
78 Posts
92TripleBlack said:
Mine was different. Like a metal clink ting noise that happened when you started applying gas from a complete stop.
I have the same problem it start when I got the brake fix "final one" I am to busy to take my mada to the dealer... :(
 

·
Premium Member
Joined
·
4,363 Posts
poison_blood said:
I have the same problem it start when I got the brake fix "final one" I am to busy to take my mada to the dealer... :(
Takes a little time to do. They need to install new seals or something when they do it. They ordered the parts for mine and I dropped it off for a couple hours. ;)
 

·
Premium Member
Joined
·
32 Posts
I had this problem. Squeaks from front suspension when turning and going up my driveway. Dealer confirmed this squeak and fixed it. They told me the bushings were worn out. At about 8 or 9 thousand miles. I don’t think so. Whatever!
 

·
Premium Member
Joined
·
9 Posts
I have been fighting a creaking/cracking noise in the front end of my Armada for over a year. The dealer finally found the source of the noise. It was really two problems. They found excessive play in both outer sway bar links. The sway bar bushings were split and would not stay in the retainers. They replaced the sway bar links and bushings. The second noise (cracking/creaking when pulling into the driveway) was found by using 'chasis ears'. They stated the lower control arm bushings were binding against the frame. They remove the control arm and lubed the bushings, reposition the control arm. I am not to happy that it took over a year to find this, but happy the dealer stuck with it. I am noise free now in the front end of the vehicle. I hope this helps someone else in diagnosing their problem. :D
 

·
Premium Member
Joined
·
3,409 Posts
dkerns said:
I have been fighting a creaking/cracking noise in the front end of my Armada for over a year. The dealer finally found the source of the noise. It was really two problems. They found excessive play in both outer sway bar links. The sway bar bushings were split and would not stay in the retainers. They replaced the sway bar links and bushings. The second noise (cracking/creaking when pulling into the driveway) was found by using 'chasis ears'. They stated the lower control arm bushings were binding against the frame. They remove the control arm and lubed the bushings, reposition the control arm. I am not to happy that it took over a year to find this, but happy the dealer stuck with it. I am noise free now in the front end of the vehicle. I hope this helps someone else in diagnosing their problem. :D
never had this problem, but I'm Glad they fixed it for you :2cool:
 

·
Premium Member
Joined
·
2 Posts
dkerns said:
I have been fighting a creaking/cracking noise in the front end of my Armada for over a year. The dealer finally found the source of the noise. It was really two problems. They found excessive play in both outer sway bar links. The sway bar bushings were split and would not stay in the retainers. They replaced the sway bar links and bushings. The second noise (cracking/creaking when pulling into the driveway) was found by using 'chasis ears'. They stated the lower control arm bushings were binding against the frame. They remove the control arm and lubed the bushings, reposition the control arm. I am not to happy that it took over a year to find this, but happy the dealer stuck with it. I am noise free now in the front end of the vehicle. I hope this helps someone else in diagnosing their problem. :D

Glad to hear you have got it licked..I am going to my dealer tomorrow for the same thing..thanks to youse guys..I am gonna print this thread and tell them ...here's the problem! Thanks again.
 

·
Premium Member
Joined
·
547 Posts
Good idea! Might do the same when I have mine checked on Tuesday.
swag said:
Glad to hear you have got it licked..I am going to my dealer tomorrow for the same thing..thanks to youse guys..I am gonna print this thread and tell them ...here's the problem! Thanks again.
 

·
Premium Member
Joined
·
459 Posts
I have the same problem and gonna print this thread too..
Thanx all
 
1 - 15 of 15 Posts
Top