Nissan Armada & Infiniti QX56 Forums banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
2 Posts
Discussion Starter #1
I have had the vehicle now for 6 weeks and have come across my first nail in the tire. I noticed the nail before the monitor system, to which it alarted me a few minutes later due to a drop in preasure. I had the nail pulled and plugged to which it is showing me a low tire (even though all are at 35 psi). Anyone else with a similar problem with a possible fix?

Other than this, I have had no problems other than excessive brake dust accumulation.

Thanks,

Jason Boeckers
 

·
Premium Member
Joined
·
258 Posts
Only one run-in with the tire pressure monitors. When my tires were rotated, the bubbas reset the pressure on all four to 32psi. Next morning, tire press warning sang out. Filled tires to 35psi and the warning light reset itself within 5 minutes.
 

·
Premium Member
Joined
·
6 Posts
i am not sure what to do in this case, but i noticed that my Armada is supposed to have this LED on the back of the steering wheel or column, is that where it is located and do all Armada's come with this monitor as standard? :confused:
 

·
Administrator
Joined
·
5,215 Posts
Tire Pressure Indicator

The low tire pressure indicator is on the left side of the instrument cluster. You will see it (as well as all others) when you turn on the ignition, before starting. (Check your owners manual)
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
4 Participants
scr38
Nissan Armada & Infiniti QX56 Forums
Club Armada is the premier Nissan Armada forum! Here you can discuss and review your favorite SUV with fellow owners.
Full Forum Listing
Top