Nissan Armada & Infiniti QX56 Forums banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
1,455 Posts
Discussion Starter #1
I started the Mada the other day and while I was driving all of a sudden the VDC, Brake and Slip light up on the instrument cluster. I got to where I was going and turned it off and started it again they were not lit. Started it up again to day and it did the exact same thing. Has anybody experienced this and any help is appreciated.
 

·
Premium Member
Joined
·
1,431 Posts
check your brake fluid, probably just a little low.
 

·
Premium Member
Joined
·
258 Posts
I've had this happen...actually happened to the wife. Dry road. Average day. She pulled over, shut it down and waited a couple of minutes. No further problems.

I checked all the fluids, connections, etc etc etc. Couldn't find anything. Never came back.

Not a good answer, I know. But keep your fingers crossed.
 

·
Premium Member
Joined
·
37 Posts
I had the same issue. If you have low brake fluid the lights will come on. Sometimes the lights will come on and go off again if you are driving on hills. Just fill the fluid back up and your good to go.
 

·
Premium Member
Joined
·
1,455 Posts
Discussion Starter #5
Thanks guys for the tips and I will try that and hopefully it works. BTW where I live that is all we have is hills. Thanks again.
 

·
Premium Member
Joined
·
1 Posts
Just had ours in with the same dash lights: brake, VDC, slip. Also, the parking brake wouldn't completely disengage. Dealer said it was excessive runout and did the brake recall work: new rotors and pads up front, turned rotors and new pads out back. Had the work done a week and a half ago - all seems well. Not sure it completely makes sense to me. I could see the sensor issue, but not the parking brake issue. Still, repaired under warranty is very nice.
 

·
Registered
Joined
·
6 Posts
I had the same issue. If you have low brake fluid the lights will come on. Sometimes the lights will come on and go off again if you are driving on hills. Just fill the fluid back up and your good to go.
Yesterday the Brake, VDS and amber Slip lights came on. Rebooting the car does not work and the brake fluid is not low.
My experience with the Nissan dealership is somewhere between bad and horrible.
Thank you
 

·
Premium Member
Joined
·
1,286 Posts
Yesterday the Brake, VDS and amber Slip lights came on. Rebooting the car does not work and the brake fluid is not low.
My experience with the Nissan dealership is somewhere between bad and horrible.
Thank you
Bring your truck to a reputable shop that utilizes a full range scan/diagnostic tool. It could be the brake booster or the brake pressure sensors under the master cylinder.
 
1 - 9 of 9 Posts
Top